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3-D Keyboard at a Glance

3-D Keyboard gives you an easy way to type all the interesting and useful
characters in your fonts. While it is running you can switch between twelve
different keyboard layouts simply by pressing a key or making a selection from
the menu shown below.

For example, you can switch to the French layout simply by pressing “Ctrl+F”
or choosing from the menu. This lets you easily type words like tête-à-tête or
fiancée. You can then switch back to the standard U.S. keyboard (or to any
other layout) by pressing another key or choosing from the menu again.

In addition to supporting foreign languages, 3-D Keyboard provides an
Enhanced U.S. keyboard layout which lets you easily type fractions, currency
signs, typographical symbols, etc.
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When 3-D Keyboard is running, each alphanumeric key on your keyboard can
type three symbols, not just two.

Our keyboard layouts follow the national standards — but you don't have to.
3-D Keyboard lets you customize our layouts to your heart's content. For
example, suppose you like the Spanish keyboard, but you wish it had the
copyright symbol on the C key, in addition to C and c. And the registered
trademark symbol on the R key. And perhaps the bullet on the O key. You
might even like to type the typographical quotation marks…

With 3-D Keyboard all this is a breeze. You can assign any character in the
Windows ANSI character set to any key using a simple drag-and-drop
procedure. It took only a few seconds to create the customized Spanish layout
shown below.

3-D Keyboard cooperates with other Windows applications. If you want to see
the current keyboard layout as you work on your documents, position the 3-D
Keyboard window next to (or even over) your application window. The 3-D
Keyboard window will show a map of the current keyboard layout.
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If you remember the layout and do not need a visual map of your keyboard,
shrink the 3-D Keyboard window to an icon. As you switch between layouts,
the letters on the icon will remind you which layout is in effect.

3-D Keyboard lets you customize almost every aspect of its operation. The
Options menu, shown below, lets you choose the font size and colors used for
drawing the keyboard display, whether to keep the 3-D Keyboard window and
icon on top of other windows at all times, etc.

Some items on this menu lead to dialog boxes where you enter your settings.
The dialog box shown below lets you assign your own hot keys for switching
between keyboard layouts.
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Another dialog lets you change the colors used in the 3-D Keyboard window.

An extensive context-sensitive Help system is always available when you are
using 3-D Keyboard.
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You don't need any special fonts to type the characters supported by 3-D
Keyboard. The special symbols and foreign letters are all part of the ANSI
character set used by Windows 3.1.

Most TrueType fonts included with Windows 3.1 are based on the ANSI set.
Any other fonts that you may buy separately, be they TrueType, PostScript, or
bitmapped fonts, will work with 3-D Keyboard, if they are based on the ANSI
character set. As long as you use such standard fonts, whether they are built
into your printer, programmed on a cartridge, or downloaded from disk, you
will be able to see all these special symbols and foreign letters on your screen
and print them with your printer:

0123456789
!#$%‰&'"‚„‘’“”«»‹›<>()[]{}*+-±/=–—¬­¯,.:;…?@|\~˜^_`
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
ƒ†‡ˆ°´¸•·¢£¥¤¦§¨™®©ªºµ¶¹²³¼½¾¿¡
ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖ×ØÙÚÛÜÝÞŸß
àáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿŠšŒœ
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System Requirements

This version of 3-D Keyboard:

• Works with Microsoft Windows 3.1 or later and WIN-OS/2 (using OS/2
version 2.1 or later)

• Is compatible with all hardware and software supported by Microsoft
Windows

• Uses approximately 140 Kilobytes of disk space and may be installed on a
hard disk, a floppy disk, or a network drive

• Was not designed to work with DOS applications
• May have conflicts with some applications that communicate with the

keyboard in unconventional ways; known incompatibilities of this kind are
listed in the Appendix  (p. 31)

Printer requirements are determined by your printing needs. 3-D Keyboard lets
you type any letters and symbols from the Windows ANSI character set. Your
applications (i.e. your word processor, spreadsheet, database manager, etc.)
control the way these letters and symbols are printed. Most applications can
print all ANSI symbols if they exist in the printer font that you are using. Most
TrueType and PostScript fonts include all ANSI symbols. See Windows Fonts
and 3-D Keyboard (p. 28) for additional information.
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Installation

Automatic Installation

An automatic installation program is included with 3-D Keyboard. Follow
the instructions below for starting this program, then follow its on-screen
prompts. Context-sensitive help is available at every step of the
installation. To use it, press the F1 key or click the Help button.

The installation program copies the required files to a directory that you
specify and creates a Program Manager group with an icon for 3-D
Keyboard.

The installation program does not make any changes to
AUTOEXEC.BAT, CONFIG.SYS, SYSTEM.INI, WIN.INI, or any other
system files.

After installation, use the Help menu in the 3-D Keyboard window for
detailed information on using the program. You may also want to read
Getting Started (p. 9), which has step-by-step instructions for new users of
3-D Keyboard.

If you later decide to remove 3-D Keyboard from your computer, consult
Files Used by 3-D Keyboard (p. 25).

Starting the Installation Program

To start the installation program:

1. Turn on your computer and start Windows.
2. Insert the distribution diskette in drive A or B.
3. Choose the “Run” command from the File menu of Program Manager

or File Manager.
4. Type a:\install or b:\install (depending on whether the diskette is in

drive A or B).
5. Press Enter.

When asked to enter the directory where you want to install 3-D
Keyboard, type or edit the full path, e.g. C:\3DKBD or
D:\UTIL\KEYBOARD. If the suggested path is acceptable, you may leave
it as is.
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If you have installed 3-D Keyboard before, the installation program will
tell you which version was installed and offer to let you overwrite it. If you
do not want to overwrite it, you will need to type a different directory.

Click the Begin button to begin installation, or the Cancel button if you do
not wish to install 3-D Keyboard right now.

Asking for Help

To read instructions and explanations in the on-screen Help system of the
installation program:

• Press F1 or click the Help button in the installation program window or
in any dialog box that displays a message

Interrupting the Installation

To abort the installation after it starts:

• Press Esc or Enter, or click the Cancel button
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Getting Started

Starting 3-D Keyboard

You can start 3-D Keyboard the same way you start other Windows
applications:

• From its Program Manager group — open the group, then double-click
the 3-D Keyboard icon (a group for 3-D Keyboard is created by the
installation program)

• From a File Manager directory window — double-click 3DKBD.EXE
or highlight it and press Enter

• By using the “Run” command on the File menu of File Manager or
Program Manager — choose Run, type 3DKBD.EXE and press Enter; if
the file is not in your current directory, add the full path, e.g.
D:\UTIL\KEYBOARD\3DKBD.EXE.

Typing With a Different Keyboard Layout

3-D Keyboard provides a slow way and a quick way to switch keyboard
layouts. This section describes the slow way — choosing a layout from the
Keyboard menu.

1. Open the 3-D Keyboard group in Program Manager and start 3-D
Keyboard.

2. Start Windows Write.
3. Arrange the Write window and the 3-D Keyboard window so that both

are visible.
4. Type some text in English.
5. Choose France from the Keyboard menu in the 3-D Keyboard

window.
6. Click anywhere in the Write window.
7. Press the keys that type Q and W on the U.S. keyboard; you should

see that you have typed A and Z; glance at the keyboard map in the
3-D Keyboard window if you are not familiar with the French
keyboard layout.

8. Press the key that types [ on the U.S. keyboard (i.e. the key to the right
of P); on the French keyboard this is a “dead key” for circumflex;
dead keys don't type any letters; note that the keyboard map in the 3-D
Keyboard window now shows only circumflex letters.

9. Press the key that types Q on the U.S. keyboard and A on the French
keyboard; you should see that you have typed â (or Â if you also
pressed Shift); note that the keyboard map no longer shows the
circumflex vowels; if you want to type another letter with a
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circumflex (or any other diacritic available on the French keyboard),
you need to press a dead key again.

10. Look at the 3-D Keyboard window and note which of the Alt1 keys is
marked with a colored (or shaded, on monochrome screens) rectangle;
this is the so-called “Third symbol key.”

11. Note also that most of the keys in the top row have a third symbol
shown in the same color (or shading) as the Third symbol key; e.g.,
the 5 key has a [ as its third symbol.

12. Press and hold your Third symbol key and press the 5 key; then
release both keys; you should see that you have typed [.

13. Choose U.S. from the Keyboard menu in the 3-D Keyboard window.
14. Click anywhere in the Write window.
15. Type some text using the standard U.S. keyboard.

Choosing Hot Keys

There is a quicker and easier way to use 3-D Keyboard. It is not necessary
to have the 3-D Keyboard window visible at all times, nor is it necessary
to use the Keyboard menu for layout selection. If you assign mnemonic
“hot key” combinations to the keyboard layouts that you intend to use
often, switching between languages can be done with one keystroke.

1. Click anywhere in the 3-D Keyboard window.
2. Choose the “Hot keys...” command from the Options menu.
3. Click on the down arrow icon to the right of the list box for “U.S.”;

you should see a list of hot key combinations, e.g. Ctrl+A, Ctrl+B, etc.
4. Choose “Ctrl+U” (U for U.S.); the list should close, and the box for

U.S. should show “Ctrl+U.”
5. Click on the down arrow icon to the right of the list box for “France”;

you should see a list of hot key combinations, e.g. Ctrl+A, Ctrl+B, etc.
6. Scroll down the list and choose “Ctrl+F” (F for France); the list

should close, and the box for France should show “Ctrl+F.”
7. Click the OK button.
8. Click the down arrow icon in the top right corner of the 3-D Keyboard

window; the window should disappear (you have “minimized” it), and
the 3-D Keyboard icon should appear at the bottom of your screen.

1On most keyboards sold in Europe, this key is called Alt Gr; on PS/1 computers sold in Europe, it
is called Alt Car.
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Changing Keyboard Layouts with Hot Keys

Now that you have defined hot keys for the U.S. and France keyboard
layouts, you can switch between them without leaving the Write window
or using any menus:

1. Hold down the Ctrl key and press U, then release both keys; you will
see “US” in the 3-D Keyboard icon; when you start typing, you will
type with the U.S. keyboard.

2. Hold down the Ctrl key and press F, then release both keys; you will
see “Fr” in the 3-D Keyboard icon; when you start typing, you will
type with the French keyboard.

3. While using the French keyboard, press the key to the right of P; you
will see a circumflex in the 3-D Keyboard icon; if you press the key
that types a, you will type â.

Unless you decide to use a different set of hot key combinations, you will
not have to repeat the steps shown above under Choosing Hot Keys. The
next time you want to use French, start 3-D Keyboard and use Ctrl+U and
Ctrl+F to switch between the U.S. and France keyboard layouts. You can
do this in any application without leaving its window.

Refer to Using 3-D Keyboard (p. 12) or to the Help system of 3-D
Keyboard for instructions on all other operations.
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Using 3-D Keyboard

3-D Keyboard works only with applications written for Microsoft Windows.
When you temporarily leave Windows to work with a DOS program, or when
you exit Windows, the standard keyboard1 for your country is activated, and
the additional layouts become unavailable until you return to Windows.

General Comments

Please read these comments if you sometimes prefer using the keyboard
rather than the mouse for choosing commands and other items in Windows
menus and dialog boxes.

Windows programs use two types of keyboard commands as an alternative
to using a mouse: normal key presses, and Alt or Ctrl key combinations.

To select a menu item which contains an underlined letter, you can simply
type that letter. For example, many File menus contain the item Save As…
To select this menu item while using 3-D Keyboard, you should press the
key that is assigned to the letter A in your current keyboard layout. In the
U.S. keyboard layout, this will be the leftmost key in the third row, but
with the French layout selected, this will be the leftmost key in the second
row.

Alt or Ctrl key combinations are shown on the screen and in manuals with
a plus between them, e.g., Ctrl+A. These are sometimes called shortcuts.

The letter in the shortcut notation (e.g., A in Ctrl+A) is the one that is
printed on the key cap of your physical keyboard, not the one that may be
assigned to the key in a particular keyboard layout. For example, the
French keyboard layout has A in the second row while the physical
keyboard made for the U.S. market has A in the third row. To use the
shortcut command Ctrl+A, press the leftmost key in the third row while
holding down Ctrl, regardless of whether the U.S. or the French keyboard
layout is currently selected.

The key combination assigned to a layout as its hot key2 is not available as
a shortcut in any application. For example, if Ctrl+U is the hot key for the
U.S. keyboard layout, you cannot use this key combination as a shortcut
for the “Underline” command in your word processor. You will have to
use a menu or a button for the “Underline” command. Alternatively, you

1The standard layout is the one that is specified by accessing the International icon in Windows
Control Panel. It is usually selected when Microsoft Windows is installed.
2Some terms used in this manual are explained in the Glossary (p. 30).
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may set the hot key for the U.S. layout to a different key combination, e.g.
Ctrl+A.

Hot key settings may be changed by choosing the “Hot keys...” command
from the Options menu. See Customizing the Hot Keys (p. 18) for details.

The 3-D Keyboard Window and Icon

If you do not want to see the 3-D Keyboard window with the current
keyboard layout, you may shrink it to an icon. The appearance of the 3-D
Keyboard icon changes to indicate the currently selected layout or the
recently pressed dead key.

If the “Always on top” command on the Options menu is checked, the 3-D
Keyboard icon will always be visible, even when some other window on
your screen is maximized.

Customizing the colors used by 3-D Keyboard does not change the colors
used in its icon.

Selecting a Keyboard Layout

To select a keyboard layout, choose it from the Keyboard menu by using
the mouse or a keyboard command, or use a hot key combination
(explained below). Notice that the title bar or icon of 3-D Keyboard
changes when you select a different keyboard layout.

Menu
Switch to the 3-D Keyboard window. Choose the desired layout from the
Keyboard menu. Then switch back to your application window and return
to your work.

Hot key
Without leaving your application, press the hot key combination. Hot key
combinations are shown on the Keyboard menu next to the layout names.
If no hot key is shown for a given layout, use the “Hot keys...” command
on the Options menu to select one. See Customizing the Hot Keys (p. 18)
for details.
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Typing Letters With Diacritics

Most letters with diacritics are typed using the dead key method, though
some are assigned to regular keys. In the 3-D Keyboard window, dead
keys are marked by diacritics in an outline font.

Press a dead key. If the 3-D Keyboard window is visible, note the changed
letters on the key caps. Only those keys that can now type a letter with a
diacritic are marked. The available dead keys are also marked. If the 3-D
Keyboard window is minimized, pressing a dead key changes the
appearance of the 3-D Keyboard icon.

Press any letter key to type a letter with a diacritic. Use the Shift keys as
you normally do when typing upper case letters. Press the space bar to type
the diacritic by itself. Press another dead key (if available) to see letters
with other diacritics. Press any other key to return the keyboard to its
normal state.

Typing the Third Symbol Assigned to Some Keys

Most keyboard layouts have keys that can produce three symbols, typed
by:

• First symbol: Press the key alone
• Second symbol: Press the key with Shift held down
• Third symbol: Press the key with the “Third symbol key” held down

(explained below)

The first two symbols are typically lower and upper case letters, or a digit
and a punctuation mark, etc. The third symbol, if available, is shown in the
bottom right corner of the key cap in the 3-D Keyboard window. It is
usually displayed in a color that is not used for any other purpose.

The Third symbol key is marked by a rectangle of the same color as all
third symbols on the key caps.

If you have an IBM AT style keyboard, the Third symbol key will be Alt;
if you have an enhanced keyboard, the Third symbol key may be Left Alt,
Right Alt or either of the Alt keys. Choose the “Third symbol key”
command from the Options menu to customize this setting. See
Customizing the Third Symbol Key (p. 21) for details.
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Menus

The menu commands available in 3-D Keyboard are briefly described below.
See the corresponding sections of Using 3-D Keyboard (p. 12) and
Customizing 3-D Keyboard (p. 18) for details.

Keyboard Menu

Keyboard Layouts
Use these commands to select a keyboard layout. The key combinations
shown next to the layout names are the currently enabled hot keys. If a
layout is shown without a hot key combination, there is currently no hot
key for this layout. Hot keys may be enabled, disabled, and customized by
choosing the “Hot keys...” command from the Options menu. See
Customizing the Hot Keys (p. 18) for details.

Pressing a hot key is a convenient alternative to using this menu,
especially when the 3-D Keyboard window is minimized or hidden by
other windows. Hot keys work only while you are using Windows
applications. They cease to be active after you exit 3-D Keyboard.

If several layouts have the same hot key assigned to them, pressing this hot
key repeatedly will cycle through these layouts.

Exit
Use this command when you no longer need the additional keyboard
layouts provided by 3-D Keyboard. After you exit, the standard keyboard
layout1 for your country is activated, and the additional layouts become
unavailable until you restart 3-D Keyboard.

If you do want to use the additional layouts, but do not want to see the 3-D
Keyboard window on your screen, minimize the window by clicking the
down arrow in the top right corner. The 3-D Keyboard icon will appear at
the bottom of your screen. This icon will indicate your currently selected
keyboard layout and the availability of the symbols typed after a dead key.

1The standard layout is the one that is specified by accessing the International icon in Windows
Control Panel. It is usually selected when Microsoft Windows is installed.
Menus Page 15



Options Menu

Hot keys...
Use this command to enable, disable, or customize the hot keys. Hot keys
are a convenient alternative to using the Keyboard menu for selecting
keyboard layouts, especially when the 3-D Keyboard window is
minimized or hidden by other windows. See p. 18 for details.

Colors...
Use this command to customize the colors used in the 3-D Keyboard
window. See p. 19 for details.

Edit keyboard layout...
Use this command to assign letters and symbols to different keys in the
currently selected keyboard layout. See p. 19 for details.

Third symbol key
Use this command to customize the Third symbol key. See p. 21 for
details.

Font size
Use this command to change the size of the letters and symbols that are
used to mark key caps in the 3-D Keyboard window. See p. 22 for details.

Physical keyboard
Use this command to tell 3-D Keyboard what type of keyboard is attached
to your computer. In most cases this should not be necessary, because the
program normally detects this information automatically. See p. 22 for
details.

Startup preferences...
Use this command to change the defaults for the keyboard layout and
window position on the screen. See p. 23 for details.

Always on top
When this option is checked, the 3-D Keyboard window is always
displayed on top of other windows. See p. 24 for details.

Help Menu

Contents
This command displays a list of topics in the Help system, organized by
subject.

Search for help on...
This command lets you enter a keyword to search for in the Help system.
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How to use help
This command displays instructions for using the Help system. These
instructions are part of Microsoft Windows.

About 3-D Keyboard...
This command displays information about 3-D Keyboard: the version
number, your serial number, a copyright notice, and the address, telephone
number, and e-mail addresses of Fingertip Software.

Menus Page 17



Customizing 3-D Keyboard

The term customizing does not refer to any irreversible changes in 3-D
Keyboard. All changes made through the menus of this program may be
canceled at any time by any user. These changes are recorded in the
initialization file (see p. 25). If the initialization file is deleted, all changes are
canceled.

Customizing the Hot Keys

The key combinations shown next to the layout names on the Keyboard
menu are hot keys. Pressing a hot key is the easiest way to select a
keyboard layout; you can do this even when the 3-D Keyboard window is
minimized or hidden by other windows. These hot keys work only in
Windows applications.

Hot keys may be customized by choosing the “Hot keys...” command from
the Options menu.

You may wish to customize the hot key settings if:

• You want to set up hot keys that are mnemonic for you
• You want to assign one hot key to several layouts; then you can cycle

through these layouts by repeatedly pressing this one hot key
• Your current hot key combinations are used in your applications for

other purposes (e.g., Ctrl+U may be used for the “Underline” command,
in which case you would not want Ctrl+U as a hot key)

To customize a hot key setting:

1. Choose the “Hot keys...” command from the Options menu.
2. Click the down arrow in the box next to the layout of interest.
3. Scroll through the list of available key combinations and select the

one that you like best.
4. Repeat this for all layouts that you plan to use.
5. Select None for any layout that you do not plan to use.
6. Click OK (or click Cancel to cancel all your changes).

When you select None instead of a key combination, the layout will have
no hot key assigned to it. It may still be selected from the Keyboard menu.
Remember that the key combinations assigned as hot keys in 3-D
Keyboard are not available as shortcuts in other applications. By selecting
None for some layouts you maximize the number of available shortcuts.
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If you click the Default button, all hot keys will be returned to their default
settings.

The customized settings are recorded in the initialization file (see p. 25). If
the initialization file is deleted, all settings are returned to their defaults.

Customizing the Colors

The 3-D Keyboard window uses three different colors on the key caps for:

• Symbols typed by a key alone and by a key with Shift held down
• The symbol typed by a key with the Third symbol key1 held down; the

same color marks the Third symbol key
• Dead keys

On monochrome screens, shading may be used in place of colors.

To change the current color or shading scheme, choose the “Colors...”
command from the Options menu, then select the colors you want to try.

If you click the Default button, the colors will be set to their default
values.

The customized settings are recorded in the initialization file (see p. 25). If
the initialization file is deleted, all settings are returned to their defaults.

Editing the Keyboard Layout

The keyboard layouts used in 3-D Keyboard are based on the standards for
personal computers as described in DOS manuals. If you want to move
some of the letters and symbols to different keys, select the layout that you
want to customize, then choose the “Edit keyboard layout...” command
from the Options menu.

When the Edit Keyboard Layout dialog box opens, you can use the
keyboard, the mouse, or both for selecting letters and symbols from the
character chart and assigning them to keys.

Keyboard Only
Press the Tab key until the character chart is active (you will see a double
border around it). Press the arrow keys to highlight the desired character.
Press the key you want to use when typing this character. To assign the
highlighted character to a shifted key, press the key while holding down

1See Typing the Third Symbol Assigned to Some Keys (p. 14) for details.
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Shift. To assign it as the third symbol on a key, press the key while
holding down the Third symbol key.

Keyboard and Mouse
Move the mouse pointer over the character chart. Click the character that
you want to move to a different key. Press the key you want to use when
typing this character. To assign the highlighted character to a shifted key,
press the key while holding down Shift. To assign it as the third symbol on
a key, press the key while holding down the Third symbol key.

Mouse Only
Move the mouse pointer over the character that you want to assign to a
different key. Press and hold the left mouse button. Drag the mouse pointer
over the key you want to use when typing the selected character. Note that
the mouse pointer changes shape and that the highlight on the key cap
indicates whether the key will be pressed by itself, with Shift, or with the
Third symbol key when typing the new character. Release the button.

Check the customized key in the 3-D Keyboard window; the symbol on
the key cap should immediately reflect your change. Repeat these steps for
each key you want to customize, then click the OK button to finalize your
changes. If you want to edit another keyboard layout, select it and repeat
these steps. If you close the Edit Keyboard Layout dialog box by using its
Control menu, your changes will be canceled.

Use the Undo button to cancel your latest change. Use the Cancel button to
cancel all changes made since you opened the Edit Keyboard Layout
dialog box. The Default button will be enabled if you have made any
changes to the default key assignments for this layout. Use this button to
return all key assignments to their defaults. Use the Help button to display
Help text.

Third symbols may be erased from keys by using the eraser in the bottom
right corner of the character chart. Choose the eraser, then drop it onto the
key or press the key while holding down the Third symbol key.

If you assign the same dead key symbol to two or more keys, only one of
these keys will be “dead.” The other key(s) will simply type the diacritic.

Letters with diacritics (normally available after a dead key is pressed) are
assigned automatically when you assign the corresponding letters without
diacritics. A letter with a diacritic may also be assigned directly to any
key. You may wish to do this if you want to avoid using dead keys.
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Notes on the Character Chart
Some symbols on the chart look like a thick vertical bar. These character
positions are not used in Windows 3.1. In addition, some other characters
in the chart may not be available in fonts with smaller character sets. See
Windows Fonts and 3-D Keyboard (p. 28) for more details.

The first character in the fifth row is the so-called non-breakable space. It
is used by some programs to indicate a space between words that should
not be split across lines.

The fourteenth character in the fifth row is the so-called soft hyphen. It is
used by some programs to indicate a hyphen that should be displayed and
printed only if the word is split between two lines at this point. Other
programs may use it for different purposes, e.g. to display a non-breakable
hyphen.

Warning
To finish editing the current keyboard layout, you must close the Edit
Keyboard Layout dialog box. This is done by clicking OK or Cancel, or by
using the Control menu (also called the System menu). If you close this
dialog box by clicking Cancel or by using its Control menu, your changes
will be canceled.

While it is possible to switch to another program without closing the
dialog box, 3-D Keyboard will not translate keystrokes until the Edit
Keyboard Layout box is closed.

The changes made in the keyboard layouts are recorded in the
initialization file (see p. 25). If the initialization file is deleted, all settings
are returned to their defaults.

Customizing the Third Symbol Key

Depending on the type of keyboard attached to your computer, you may
designate either one or both of the Alt keys for typing the third symbol
assigned to some keys. The current Third symbol key is marked with a
colored rectangle in the 3-D Keyboard window. If your physical keyboard
has only one Alt key, you cannot customize the Third symbol key setting.

To customize this setting, choose the “Third symbol key” command from
the Options menu, then choose Left Alt, Right Alt, or Either Alt.

One reason for customizing the Third symbol key is to avoid certain
conflicts in the following functions of the Alt keys:
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Activating the Menu Bar
In Microsoft Windows, pressing and releasing an Alt key activates the
menu bar in the current window. This function is still available when the
Either Alt option is selected. When only one of the two Alt keys is set to
be the Third symbol key, this Alt key does not activate the menu bar.

Using Alt+Function Key
Some programs use combinations of Alt and function keys as shortcuts,
e.g. Alt+F4 for the “Exit” command in many Windows applications. This
function is still available when the Either Alt option is selected. If only one
of the two Alt keys is set to be the Third symbol key, this Alt key cannot
be used for such shortcuts.

Using Other Shortcuts with Alt
Some programs use the Alt key in menus and dialog boxes; pressing Alt
with an alphanumeric key selects an option. This function is still available
when the Either Alt option is selected, but only for alphanumeric keys
which do not have a third symbol on them. If only one of the two Alt keys
is set to be the Third symbol key, this Alt key cannot be used for such
shortcuts.

The customized setting is recorded in the initialization file (see p. 25). If
the initialization file is deleted, all settings are returned to their defaults.

Selecting the Font Size

The characters that are used to mark key caps in the 3-D Keyboard
window may seem too large or too small on your screen. To change their
size, choose the “Font size” command from the Options menu, then choose
the desired size.

The new font size is recorded in the initialization file (see p. 25). If the
initialization file is deleted, all settings are returned to their defaults.

Selecting the Physical Keyboard

In most cases, this operation is unnecessary, because 3-D Keyboard
automatically identifies the type of keyboard attached to your computer
(e.g., the IBM AT keyboard, the IBM PS/2 keyboard, etc.). Should you
suspect that your keyboard has not been identified correctly, choose the
“Physical keyboard” command from the Options menu and select the
model that matches your keyboard. Be careful not to misuse this
command, or the layout displayed in the 3-D Keyboard window will not
match your physical keyboard.

Page 22 3-D Keyboard 2.4 User's Guide



If you try to select another physical keyboard, and find that the menu
option you desire is disabled (i.e. shown in gray rather than black), you
should run Windows Setup and make sure that Windows itself has the
correct information about your keyboard.

This version of 3-D Keyboard will work with the enhanced 102-key
keyboard found on computers sold outside the U.S., but since the 102-key
keyboard has more keys and a somewhat different layout, the layout
displayed in the 3-D Keyboard window will not match the actual
keyboard. Non-U.S. versions of 3-D Keyboard support the 102-key
keyboard; these may be purchased from Fingertip Software.

The physical keyboard selection is recorded in the initialization file (see p.
25). If the initialization file is deleted, all settings are returned to their
defaults.

Selecting the Startup Preferences

You can specify a keyboard layout and window position that will be used
whenever 3-D Keyboard is started. To do this, choose the “Startup
preferences...” command from the Options menu, and make your
selections in the Startup Preferences dialog box which appears.

It is convenient to select the keyboard layout that is most useful to you as
the initial layout. To do so, select the desired layout in the drop-down
“Keyboard layout” list box.

To specify whether the 3-D Keyboard window opens in the top left,
bottom left, top right, or bottom right corner of the screen, check the
corresponding radio button.

If you check the box “Remember icon position from last session,” then the
position of the keyboard icon on your screen will be recorded each time
3-D Keyboard exits, and the next time you start and minimize the
program, the icon will be placed in the same position on the screen.

If you click the Default button, all startup preferences will be returned to
their default settings.

The new startup preferences are recorded in the initialization file (see p.
25). If the initialization file is deleted, all settings are returned to their
defaults.
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Always on Top

When this option is checked on the Options menu, the 3-D Keyboard
window is always displayed on top of all other windows. In other words, it
may block other windows, but it will not be blocked by them. Similarly,
the 3-D Keyboard icon is displayed on top of other windows and icons and
is always visible, even when the window of some other application is
maximized. This may be convenient if you want to see the keyboard layout
or the icon while working with other applications whose windows are very
large or maximized.

The setting for this option is recorded in the initialization file (see p. 25). If
the initialization file is deleted, all settings are returned to their defaults.
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Additional Information

Most users should never have a reason to use the information provided below.
We include it here for those who like to know technical details.

Files Used by 3-D Keyboard

The four distribution files described below must be located in the same
directory; the installation program for 3-D Keyboard places these files in
the directory that you specify. The initialization file, also described below,
is not distributed with 3-D Keyboard; it is created in the Windows
directory during installation and updated as you customize various options
of the program.

3DKBD.EXE is the executable program file. Its name, together with the
directory name, should be used when creating a Program Manager item for
3-D Keyboard. The installation program for 3-D Keyboard normally does
this for you.

3DKBD.DLL is an auxiliary file that is required for operation of the
program.

3DKANSI.FON contains the 3-D Key Caps screen fonts. They are used
only in the 3-D Keyboard window.

3DKBD.HLP contains the help system for the program.

3DKBD.INI is the initialization file that is read by 3-D Keyboard when
the program starts. This file is created in your Windows directory when
you install 3-D Keyboard. It is updated whenever you customize any
option of the program. If this file is deleted, all settings are returned to
their defaults.

The Initialization File

The initialization file, 3DKBD.INI, is created in the Windows directory
when you install 3-D Keyboard. It is updated whenever you customize any
option of the program.

If the initialization file is deleted, all settings are returned to their defaults.

You should not need to edit this file; all settings are recorded
automatically by 3-D Keyboard as you make changes via the Options
menu. The file format is explained below for those who like to know such
things.
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The following is an example of the entire contents of an initialization file:

[Colors]
NormalCharacter=128 0 0
ThirdSymbol=0 128 0
DeadKey=255 255 0

[Hot Keys]
EnhancedUS=48
France=112
Germany=189
Italy=191
LatinAmerica=0
US=65

[Keyboard Layouts]
EnhancedUS=12...l;'!`\z...m,./!!@#$%!^&*...1

[Settings]
SymbolKey=3
PhysicalKeyboard=4
FontSize=1
AlwaysOnTop=1
Directory=C:\3DKBD
Version=2.4
Password=############

[Startup Preferences]
KeyboardLayout=Enhanced U.S.
WindowPosition=3
IconX=465
IconY=0

; End of this 3DKBD.INI file.
A semicolon may be used to introduce a comment line; all text on a line
that begins with a semicolon is ignored by 3-D Keyboard.

The Colors Section
The names are the same as in the Colors dialog box in 3-D Keyboard, with
spaces and punctuation removed. The numbers are the decimal values for
the red, green, and blue components, in that order. These values must be
between 0 and 255. The following combination, for example, defines pure

1Only part of this line is shown here; ellipses indicate the omitted parts. The actual line contains up
to 282 characters.
Page 26 3-D Keyboard 2.4 User's Guide



red: 255 0 0. Windows Paintbrush shows these numbers when you use the
“Edit Colors...” command on its Options menu.

The Hot Keys Section
The names of those layouts whose hot keys have been customized are
listed here. All spaces and punctuation are removed from the layout
names. The numbers to the right of the equal sign are the virtual key codes
used by Windows programmers; they are published in Microsoft technical
reference manuals. For letters and digits these are the same as ASCII
codes.

The Keyboard Layouts Section
Only those layouts that have been customized appear in this section. The
names for the layouts are the same as in the Hot Keys section. The
characters to the right of the equal sign show the current key assignments;
they roughly follow the order of the keys on the keyboard; more precisely,
they follow the order of scan codes. An exclamation point precedes every
dead key. An exclamation point that does not mark a dead key is shown
twice. Do not edit this section of the initialization file; any key
assignments may be done with more precision and ease by using the “Edit
keyboard layout...” command.

The Settings Section
SymbolKey defines the setting for the Third symbol key: 1 stands for Left
Alt, 2 for Right Alt, 3 for Either Alt.
FontSize defines the setting for the size of the font used to mark key caps
in the 3-D Keyboard window: 1 stands for Small, 2 for Large.
PhysicalKeyboard defines the setting for the Physical keyboard: 2 stands
for AT, 3 for 101-key Enhanced, 4 for 101-key with L-shaped Enter.
AlwaysOnTop defines whether or not the 3-D Keyboard window and icon
will always stay on top of other windows on your screen: 1 stands for Yes,
0 for No.
Directory is the directory where 3-D Keyboard was most recently
installed.
Version is the version number of 3-D Keyboard that was most recently
installed.
Password is your password (an encoded form of your serial number).

[Startup Preferences]
KeyboardLayout defines the setting for the default keyboard layout.
WindowPosition defines the initial position of the 3-D Keyboard window
on the screen: 1 stands for the top left corner, 2 for the bottom left corner,
3 for the top right corner, and 4 for the bottom right corner.
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IconX and IconY are the screen coordinates, in pixels, of the 3-D Keyboard
icon when the program last exited. These lines appear in the INI file only
if the box “Remember last icon position” is checked in the Startup
Preferences dialog box.

Control Panel and 3-D Keyboard

Control Panel is a program that is included with Microsoft Windows. It
lets you change the configuration of your system, including the keyboard
layout. This version of 3-D Keyboard requires that the keyboard layout in
Control Panel be set to “US.” If 3-D Keyboard detects that another layout
is selected, it will instruct you to start Control Panel, choose the
“International” icon, and reset the keyboard layout.

This requirement does not impair any flexibility of Windows, since 3-D
Keyboard provides an easy way to switch between keyboard layouts.

The rest of the settings, e.g. the date and currency format, may be selected
as desired.

The 3-D Key Caps Font

While 3-D Keyboard is running, some applications may include the 3-D
Key Caps (ANSI) font in the list of available fonts. This is the font that is
used in the 3-D Keyboard window. Avoid using this font in your
documents, because it has a very limited range of point sizes and was not
designed for printing text.

Windows Fonts and 3-D Keyboard

ANSI Fonts
Most Windows applications use the ANSI character set in their fonts. 3-D
Keyboard can be used with all ANSI fonts.

ANSI TrueType and PostScript fonts contain 22 characters that are not
found in most other types of ANSI fonts. These characters include the
large bullet, the trademark symbol, and the two daggers. 3-D Keyboard
allows you to type the full ANSI character set, including these 22
characters. However, you will be unable to see these characters when
using fonts that lack them (e.g. Courier, MS Sans Serif, or MS Serif).

Non-ANSI Fonts
Most non-Windows programs for personal computers use the IBM PC
extended character set. The authors of Microsoft Windows refer to it as the
OEM character set. Windows includes one OEM font called Terminal. Do
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not use this font with 3-D Keyboard. When using the Windows Terminal
program, select some other font from the Terminal Preferences options on
the Settings menu.

In general, this version of 3-D Keyboard is not very useful for typing
characters in non-ANSI fonts such as Symbol, Terminal, or Wingdings.
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Appendix

Glossary

Below you will find a short glossary of terms used in this manual. Some of
these terms are used in guides to Windows applications and in the User's
Guide supplied with Microsoft Windows.

ANSI vs. OEM character sets
Most Windows fonts use the so called ANSI character set. ANSI stands for
American National Standards Institute. Most non-Windows programs for
personal computers use the so called IBM PC extended character set,
which the authors of Microsoft Windows refer to as the OEM character
set. Windows includes one OEM font called Terminal. Your manual for
Microsoft Windows has charts for both of these character sets.

customization
Customization in this manual does not refer to any irreversible changes in
3-D Keyboard. All changes made through the menus of this program may
be canceled at any time by any user. These changes are recorded in the
initialization file (see p. 25). If the initialization file is deleted, all changes
are canceled.

dead keys
Dead keys, when pressed, do not type any letters or symbols. Their
purpose is to make additional letters available, typically letters with
diacritics. The letter with the diacritic will be typed when its key is pressed
after the dead key. For example, to type Ö with the Enhanced U.S.
keyboard, press the Umlaut dead key and then press O while holding down
Shift.

diacritics
Diacritics are marks added to letters in order to distinguish them from
other letters of similar form, e.g. the tilde over the Spanish letter ñ. In most
keyboard layouts, letters with diacritics are typed using the dead key
method.

hot keys
A hot key is a key combination which selects a certain keyboard layout
when pressed. Hot keys are very convenient; they work even when the 3-D
Keyboard window is minimized or hidden by other windows, though they
cease to be active when you switch to a DOS application or exit 3-D
Keyboard.
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Your current hot keys are shown next to the layout names on the Keyboard
menu. The letter in the hot key notation is the one that is printed on the key
cap of your physical keyboard, not the one that may be assigned to the key
in a particular keyboard layout. If no hot key is shown, then none has been
assigned. See Selecting a Keyboard Layout (p. 13) and Customizing the
Hot Keys (p. 18) for more details.

password
A password is a 12-character sequence which contains an encoded form of
your serial number.

serial number
Your serial number uniquely identifies your copy of 3-D Keyboard. You
can see your serial number by choosing “About 3-D Keyboard...” on the
Help menu. Note that you must include your serial number with all
requests for technical support.

shortcuts
Shortcut key combinations are keyboard alternatives to using menus. For
example, in many Windows applications, pressing C while holding down
the Ctrl key is equivalent to choosing the “Copy” command from the Edit
menu. Shortcuts are specific to applications and can be used only when the
application window is active.

A shortcut key combination, if it exists, is shown on the menu next to the
command. The notation Ctrl+C, for example, means “press C while
holding down Ctrl.” The letter in the shortcut notation is the one that is
printed on the key cap of your physical keyboard, not the one that may be
assigned to the key in a particular keyboard layout.

Limitations of This Version

This version of 3-D Keyboard has the following limitations:

ANSI Fonts
All keyboard layouts are designed to be used with ANSI fonts; 3-D
Keyboard does not work with the Symbol, Terminal, or Wingdings fonts,
but it does work with the Terminal program when an ANSI font is
selected. See Windows Fonts and 3-D Keyboard (p. 28) for more details.

After Dark
When using 3-D Keyboard with After Dark, you should use the standard
U.S. keyboard layout when setting the password. Before typing the
password, press Caps Lock so that you type in upper case.
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Claris Works 1.0
Because Claris Works 1.0 treats keyboard input in unconventional ways,
some hot keys and third symbols do not work while certain Claris Works
dialogs are open. To avoid this limitation, select hot keys other than
“Ctrl+F1” or “Ctrl+Letter” (where “Letter” is any letter from A-Z), and set
the Third Symbol Key to Right Alt or Left Alt instead of Either Alt. See
Customizing the Hot Keys (p. 18) and Customizing the Third Symbol Key
(p. 21) for more details.

Microsoft Windows Recorder
When using the Microsoft Windows Macro Recorder, do not assign your
macros to Alt key combinations because they are not played back correctly
while 3-D Keyboard is running. Use Shift and/or Ctrl key combinations
instead.

Microsoft Windows Calculator
3-D Keyboard does not translate keystrokes properly when used with the
Microsoft Windows Calculator.

102-key Keyboards
This version of 3-D Keyboard was written for computers sold in the US. It
will work with the enhanced 102-key keyboard found on computers sold
outside the US, but since the 102-key keyboard has more keys and a
somewhat different layout, the layout displayed in the 3-D Keyboard
window will not match the actual keyboard. Non-US versions of 3-D
Keyboard support the 102-key keyboard; these may be purchased from
Fingertip Software.

Future and Related Products

We welcome your suggestions for future versions of 3-D Keyboard. Some
features currently under consideration include:

• The capability to place 4 characters on each key
• Support for additional keyboard layouts
• Native versions for Windows 95 and OS/2 Warp

Sending Suggestions for Improvement

The creators of 3-D Keyboard, Peter Cassetta and Slava Paperno, welcome
any suggestions you might have for improving this product. They may be
reached through Fingertip Software (see the title page for contact
information).
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Technical Support

Feel free to contact Fingertip Software as needed for technical support (see
the title page for contact information). Note that you must include your
serial number with all support requests.

Whenever possible, please use e-mail for technical support. Requests are
normally answered within 24 hours. If your question is urgent, however,
we will be glad to provide support over the telephone.
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License Agreement

Grant of license. Under this license you may:

a) Use 3-D Keyboard (the “software”) on only one machine at a time,
unless an agreement with Fingertip Software (“Fingertip”) specifies
otherwise

b) Copy the software for backup
c) Transfer possession of the software to another party

Copyright. The software is licensed to you by Fingertip and is protected by
United States copyright laws and international treaty provisions. Therefore,
you must treat the software like any other copyrighted material.

Restrictions. You may not rent or lease the software, but you may transfer the
software on a permanent basis provided you retain no copies and the recipient
agrees to the terms of this Agreement. If the software is an update, any transfer
must include the update and all prior versions.
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Limited Warranty and Customer Remedies

Limited warranty. Fingertip warrants that the software will perform
substantially in accordance with the documentation in this User's Guide or the
on-line Help system, and that any diskettes or printed documentation supplied
will be free from defects for a period of ninety (90) days from the original
purchase date.

Customer remedies. Fingertip's entire liability and your exclusive remedy
shall be, at Fingertip's option, either a) refund of the price paid or b) repair or
replacement of the software that does not meet Fingertip's Limited Warranty.
Refunds shall require that any disks and printed documentation received be
returned to Fingertip with a copy of your receipt or other proof of purchase.
This Limited Warranty is void if failure of the software has resulted from
accident, abuse, or misapplication.

No other warranties. Fingertip disclaims all other warranties, either express or
implied, including but not limited to implied warranties of merchantability and
fitness for a particular purpose, with respect to the software and the
accompanying documentation in this User's Guide or the on-line Help system.
This limited warranty gives you specific legal rights. You may have other
rights which vary from state to state.

No liability for consequential damages. In no event shall Fingertip or its
suppliers be liable for any damages whatsoever (including but not limited to,
damages for loss of business profit, business interruption, loss of business
information, or other pecuniary loss) arising out of the use or inability to use
this product, even if Fingertip has been advised of the possibility of such
damages. Because some states do not allow the exclusion or limitation of
liability for consequential or incidental damages, the above limitation may not
apply to you.

This agreement is governed by the laws of the State of Texas.

Fingertip Software, P.O. Box 2487, Universal City, TX 78148, USA, (210)
659-2532.
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initialization file, 25
installation, 7
keyboard layout

customizing, 19
selecting, 9, 13

Keyboard menu, 15
license agreement, 34
limitations, 31
menus, 15
OEM, 28, 30
Options menu, 16
OS/2 Warp, 32
password, 31
physical keyboard, 12, 22
printer requirements, 6
Recorder, 32
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